Jump to content

  • Free consultations and support
  • Live chatClick Here for Live Chat
  • Call ico 1888-906-1888
    Phone support: Open

    Ready for your call :)

    Our business hours:

    Mon — Fri, 2am — 8pm (EST)

    US & EU support teams

    Phone support: Closed

    We are back in: 1h 20m

    Our business hours:

    Mon — Fri, 2am — 8pm (EST)

    US & EU support teams

"Something went wrong" notification Copyright

Copyright Transfer Agreement Copyright Something went wrong

  • Please log in to reply

#1 joaquin_degraaff


    Junior Member

  • Designer
  • 1 posts

Posted 21 October 2022 - 10:01 AM

Hi there,


Today I finished a One-To-One project and i am trying to sign the Copyright Transfer Agreement but it keept saying "Something went wrong".

And I have no clue on what it could be, I have done One-To-One projects before and it went perfectly fine. 

I tried restarting my wifi, I tried to sign the agreement in another browser and on another device, but it all won't work.

Does anyone have a clue what it could be?


Joaquin de Graaff (joaquin_degraaff on DC)

#2 ramsro



  • Designer
  • 2090 posts

Posted 21 October 2022 - 03:17 PM

Hi there!


Did you also upload a source file in the corresponding tab? I got this error once when no file was added in the sources tab.

#3 sharie



  • Administrators
  • 21687 posts

Posted 21 October 2022 - 03:23 PM

HI there   I'm working on this  and have it/development working on it as well. This should be resolved soon


Thank you

Like us on facebook

#4 imaliq


    Senior Member

  • Designer
  • 229 posts

Posted 25 October 2022 - 01:23 AM

yes, there seems to be a slight problem or glitch in DC, I'm having some contests that I'm participating in that don't appear in the "my contests" or "open" tabs, but appear in "browse all contests", there are no settings I've changed and previously I I've clicked the follow button...

hopefully it's resolved quickly...


Also tagged with one or more of these keywords: Copyright Transfer Agreement, Copyright, Something went wrong

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users